disable gradle enterprise plugin; add jre8 dependency for weird jetbrains plugins
Some checks failed
Mirror / mirror (push) Failing after 1m38s
Some checks failed
Mirror / mirror (push) Failing after 1m38s
This commit is contained in:
parent
a01077dad3
commit
0e591e20a9
3 changed files with 44 additions and 3 deletions
3
.SRCINFO
3
.SRCINFO
|
@ -6,16 +6,19 @@ pkgbase = dokka
|
|||
arch = any
|
||||
license = Apache
|
||||
makedepends = gradle
|
||||
makedepends = java-runtime-headless=8
|
||||
makedepends = npm
|
||||
depends = freemarker
|
||||
depends = java-environment
|
||||
source = https://github.com/Kotlin/dokka/archive/refs/tags/v1.9.10.tar.gz
|
||||
source = 0001-enable-application-plugin.patch
|
||||
source = 0002-embed-plugin-dependencies.patch
|
||||
source = 0003-disable-gradle-enterprise.patch
|
||||
source = dokka
|
||||
sha256sums = 6ff50037806e140cff4a12b98c8e6631c2aedbd867b04dcc40ade9880c75d0fc
|
||||
sha256sums = 78d2f4fd30508c9b634e22655da275b0db4c5317d71bb3cd746f851702a31d93
|
||||
sha256sums = bef57356bd152795195100874c918fa27c35407507aa13f08267dce0b0dcc1de
|
||||
sha256sums = 2bac7e5f944f4f2342eaabff4b60666f3681dd945ff96e8bb56491c6dda4deb8
|
||||
sha256sums = 9c7aa9721fe0b2c3cf3831a4d0b1720f13b070734d7be2702f820267ca11e277
|
||||
|
||||
pkgname = dokka
|
||||
|
|
31
0003-disable-gradle-enterprise.patch
Normal file
31
0003-disable-gradle-enterprise.patch
Normal file
|
@ -0,0 +1,31 @@
|
|||
--- settings.gradle.kts.bak 2023-11-22 18:20:42.369002363 +0100
|
||||
+++ settings.gradle.kts 2023-11-22 18:21:00.853981373 +0100
|
||||
@@ -54,10 +54,6 @@
|
||||
}
|
||||
}
|
||||
|
||||
-plugins {
|
||||
- `gradle-enterprise`
|
||||
-}
|
||||
-
|
||||
include(
|
||||
":core",
|
||||
":core:test-api",
|
||||
@@ -101,17 +97,4 @@
|
||||
":docs-developer",
|
||||
)
|
||||
|
||||
-val isCiBuild = System.getenv("GITHUB_ACTIONS") != null || System.getenv("TEAMCITY_VERSION") != null
|
||||
-
|
||||
-
|
||||
-
|
||||
-gradleEnterprise {
|
||||
- buildScan {
|
||||
- termsOfServiceUrl = "https://gradle.com/terms-of-service"
|
||||
- termsOfServiceAgree = "yes"
|
||||
- publishAlwaysIf(isCiBuild)
|
||||
- }
|
||||
-}
|
||||
-
|
||||
-
|
||||
enableFeaturePreview("TYPESAFE_PROJECT_ACCESSORS")
|
13
PKGBUILD
13
PKGBUILD
|
@ -10,21 +10,28 @@ license=('Apache')
|
|||
arch=('any')
|
||||
|
||||
depends=('freemarker' 'java-environment')
|
||||
makedepends=('gradle' 'npm')
|
||||
makedepends=('gradle' 'java-runtime-headless=8' 'npm')
|
||||
|
||||
source=("https://github.com/Kotlin/dokka/archive/refs/tags/v$pkgver.tar.gz"
|
||||
'0001-enable-application-plugin.patch'
|
||||
'0002-embed-plugin-dependencies.patch'
|
||||
'0003-disable-gradle-enterprise.patch'
|
||||
'dokka')
|
||||
sha256sums=('6ff50037806e140cff4a12b98c8e6631c2aedbd867b04dcc40ade9880c75d0fc'
|
||||
'78d2f4fd30508c9b634e22655da275b0db4c5317d71bb3cd746f851702a31d93'
|
||||
'bef57356bd152795195100874c918fa27c35407507aa13f08267dce0b0dcc1de'
|
||||
'2bac7e5f944f4f2342eaabff4b60666f3681dd945ff96e8bb56491c6dda4deb8'
|
||||
'9c7aa9721fe0b2c3cf3831a4d0b1720f13b070734d7be2702f820267ca11e277')
|
||||
|
||||
prepare() {
|
||||
cd "$srcdir/dokka-$pkgver"
|
||||
patch -N -p0 -i ../0001-enable-application-plugin.patch
|
||||
patch -N -p0 -i ../0002-embed-plugin-dependencies.patch
|
||||
for patch in \
|
||||
'0001-enable-application-plugin.patch' \
|
||||
'0002-embed-plugin-dependencies.patch' \
|
||||
'0003-disable-gradle-enterprise.patch'
|
||||
do
|
||||
patch -N -p0 -i "../$patch"
|
||||
done
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
Loading…
Reference in a new issue