This commit is contained in:
parent
e5baaface5
commit
a01077dad3
3 changed files with 23 additions and 25 deletions
12
.SRCINFO
12
.SRCINFO
|
@ -1,21 +1,21 @@
|
||||||
pkgbase = dokka
|
pkgbase = dokka
|
||||||
pkgdesc = Documentation Engine for Kotlin
|
pkgdesc = Documentation Engine for Kotlin
|
||||||
pkgver = 1.8.10
|
pkgver = 1.9.10
|
||||||
pkgrel = 1
|
pkgrel = 1
|
||||||
url = https://kotlin.github.io/dokka/1.8.10/
|
url = https://kotlin.github.io/dokka/1.9.10/
|
||||||
arch = any
|
arch = any
|
||||||
license = Apache
|
license = Apache
|
||||||
makedepends = gradle7
|
makedepends = gradle
|
||||||
makedepends = npm
|
makedepends = npm
|
||||||
depends = freemarker
|
depends = freemarker
|
||||||
depends = java-environment
|
depends = java-environment
|
||||||
source = https://github.com/Kotlin/dokka/archive/refs/tags/v1.8.10.tar.gz
|
source = https://github.com/Kotlin/dokka/archive/refs/tags/v1.9.10.tar.gz
|
||||||
source = 0001-enable-application-plugin.patch
|
source = 0001-enable-application-plugin.patch
|
||||||
source = 0002-embed-plugin-dependencies.patch
|
source = 0002-embed-plugin-dependencies.patch
|
||||||
source = dokka
|
source = dokka
|
||||||
sha256sums = 53aa1464d4074434f436b388b48ed4bc5bacf33fba5758b4c0d49abbc414a14e
|
sha256sums = 6ff50037806e140cff4a12b98c8e6631c2aedbd867b04dcc40ade9880c75d0fc
|
||||||
sha256sums = 78d2f4fd30508c9b634e22655da275b0db4c5317d71bb3cd746f851702a31d93
|
sha256sums = 78d2f4fd30508c9b634e22655da275b0db4c5317d71bb3cd746f851702a31d93
|
||||||
sha256sums = b5f139af1e11ba823865f01383eb5eae873af86fcd86107e6e179076ce1145f4
|
sha256sums = bef57356bd152795195100874c918fa27c35407507aa13f08267dce0b0dcc1de
|
||||||
sha256sums = 9c7aa9721fe0b2c3cf3831a4d0b1720f13b070734d7be2702f820267ca11e277
|
sha256sums = 9c7aa9721fe0b2c3cf3831a4d0b1720f13b070734d7be2702f820267ca11e277
|
||||||
|
|
||||||
pkgname = dokka
|
pkgname = dokka
|
||||||
|
|
|
@ -1,14 +1,12 @@
|
||||||
--- runners/cli/build.gradle.kts 2022-08-21 15:44:14.274863135 +0200
|
--- runners/cli/build.gradle.kts.bak 2023-11-22 17:57:41.923139585 +0100
|
||||||
+++ runners/cli/build.gradle.kts 2022-08-21 15:58:28.329169409 +0200
|
+++ runners/cli/build.gradle.kts 2023-11-22 18:04:46.718648023 +0100
|
||||||
@@ -10,6 +15,11 @@
|
@@ -18,7 +18,9 @@
|
||||||
implementation(project(":core"))
|
|
||||||
implementation(kotlin("stdlib"))
|
|
||||||
testImplementation(kotlin("test-junit"))
|
|
||||||
+
|
|
||||||
+ val kotlinx_html_version: String by project
|
|
||||||
+ implementation("org.jetbrains.kotlinx:kotlinx-html-jvm:$kotlinx_html_version")
|
|
||||||
+
|
|
||||||
+ implementation(project(":kotlin-analysis"))
|
|
||||||
}
|
|
||||||
|
|
||||||
tasks {
|
dependencies {
|
||||||
|
implementation(projects.core)
|
||||||
|
+ implementation(projects.subprojects.analysisKotlinApi)
|
||||||
|
implementation(libs.kotlinx.cli)
|
||||||
|
+ implementation(libs.kotlinx.html)
|
||||||
|
|
||||||
|
testImplementation(kotlin("test"))
|
||||||
|
}
|
||||||
|
|
12
PKGBUILD
12
PKGBUILD
|
@ -2,7 +2,7 @@
|
||||||
# Maintainer: Dominic Meiser [git at msrd0 dot de]
|
# Maintainer: Dominic Meiser [git at msrd0 dot de]
|
||||||
|
|
||||||
pkgname='dokka'
|
pkgname='dokka'
|
||||||
pkgver=1.8.10
|
pkgver=1.9.10
|
||||||
pkgrel=1
|
pkgrel=1
|
||||||
pkgdesc='Documentation Engine for Kotlin'
|
pkgdesc='Documentation Engine for Kotlin'
|
||||||
url="https://kotlin.github.io/dokka/$pkgver/"
|
url="https://kotlin.github.io/dokka/$pkgver/"
|
||||||
|
@ -10,15 +10,15 @@ license=('Apache')
|
||||||
arch=('any')
|
arch=('any')
|
||||||
|
|
||||||
depends=('freemarker' 'java-environment')
|
depends=('freemarker' 'java-environment')
|
||||||
makedepends=('gradle7' 'npm')
|
makedepends=('gradle' 'npm')
|
||||||
|
|
||||||
source=("https://github.com/Kotlin/dokka/archive/refs/tags/v$pkgver.tar.gz"
|
source=("https://github.com/Kotlin/dokka/archive/refs/tags/v$pkgver.tar.gz"
|
||||||
'0001-enable-application-plugin.patch'
|
'0001-enable-application-plugin.patch'
|
||||||
'0002-embed-plugin-dependencies.patch'
|
'0002-embed-plugin-dependencies.patch'
|
||||||
'dokka')
|
'dokka')
|
||||||
sha256sums=('53aa1464d4074434f436b388b48ed4bc5bacf33fba5758b4c0d49abbc414a14e'
|
sha256sums=('6ff50037806e140cff4a12b98c8e6631c2aedbd867b04dcc40ade9880c75d0fc'
|
||||||
'78d2f4fd30508c9b634e22655da275b0db4c5317d71bb3cd746f851702a31d93'
|
'78d2f4fd30508c9b634e22655da275b0db4c5317d71bb3cd746f851702a31d93'
|
||||||
'b5f139af1e11ba823865f01383eb5eae873af86fcd86107e6e179076ce1145f4'
|
'bef57356bd152795195100874c918fa27c35407507aa13f08267dce0b0dcc1de'
|
||||||
'9c7aa9721fe0b2c3cf3831a4d0b1720f13b070734d7be2702f820267ca11e277')
|
'9c7aa9721fe0b2c3cf3831a4d0b1720f13b070734d7be2702f820267ca11e277')
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
|
@ -29,8 +29,8 @@ prepare() {
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cd "$srcdir/dokka-$pkgver"
|
cd "$srcdir/dokka-$pkgver"
|
||||||
gradle7 :runners:cli:distTar
|
gradle :runners:cli:distTar
|
||||||
gradle7 :plugins:base:jar
|
gradle :plugins:base:jar
|
||||||
}
|
}
|
||||||
|
|
||||||
package() {
|
package() {
|
||||||
|
|
Loading…
Reference in a new issue