patch broken qhull

This commit is contained in:
Lukas1818 2020-10-11 15:28:44 +02:00
parent 0dec62ccfd
commit a78c5ff556
2 changed files with 16 additions and 2 deletions

View file

@ -14,10 +14,12 @@ replaces=('slic3r++')
makedepends=('boost' 'cereal' 'cmake' 'eigen' 'libigl' 'openvdb' 'wxgtk2') # cmake doesn't detect wx if not both gtk2 and gtk3 are installed makedepends=('boost' 'cereal' 'cmake' 'eigen' 'libigl' 'openvdb' 'wxgtk2') # cmake doesn't detect wx if not both gtk2 and gtk3 are installed
source=("https://github.com/supermerill//SuperSlicer/archive/$_pkgtag.tar.gz" source=("https://github.com/supermerill//SuperSlicer/archive/$_pkgtag.tar.gz"
"superslicer.desktop" "superslicer.desktop"
"0001-wxgtk3-is-broken-on-wayland.patch") "0001-wxgtk3-is-broken-on-wayland.patch"
"qhull-broken.patch")
sha512sums=('fbcfa98bee8f3284c36eb33eb715ab03979c26778656d16b56485ba553f5c5702e1fb59b2b43ce0e1e0ddea1d15f278b007c7a064824df16b95d8a2f9647e928' sha512sums=('fbcfa98bee8f3284c36eb33eb715ab03979c26778656d16b56485ba553f5c5702e1fb59b2b43ce0e1e0ddea1d15f278b007c7a064824df16b95d8a2f9647e928'
'18b39d66b12453686ac0b411bac4a7c3000c541aeb0de2cacf37552a0e2435858c9ce2d3da10fa05ab6ab0e5e714f78f6a011f894435ab7195ae5f3ed8bc5623' '18b39d66b12453686ac0b411bac4a7c3000c541aeb0de2cacf37552a0e2435858c9ce2d3da10fa05ab6ab0e5e714f78f6a011f894435ab7195ae5f3ed8bc5623'
'acf35ebe467e9fb30f1b77d15348f1a7b82dcf45a5b829e375e972b5d6b49968603b3fa090c4d1f56e8b5148e2b820e79afa269da60ace70de1ceadcf6e820c5') 'acf35ebe467e9fb30f1b77d15348f1a7b82dcf45a5b829e375e972b5d6b49968603b3fa090c4d1f56e8b5148e2b820e79afa269da60ace70de1ceadcf6e820c5'
'db1857418c2fe380a5e82c3c2b67d945ceb81f40df810c9b6b64730fdbcdf0e5b45e5f6ee8d77f40547b8f078b07aa92f2011e2aaa864a69c4b13d60c2a7b912')
prepare() prepare()
{ {
@ -28,6 +30,7 @@ prepare()
# apply patches # apply patches
patch --forward --strip=1 --input="$srcdir/0001-wxgtk3-is-broken-on-wayland.patch" patch --forward --strip=1 --input="$srcdir/0001-wxgtk3-is-broken-on-wayland.patch"
patch --forward --strip=0 --input="$srcdir/qhull-broken.patch"
} }
build() build()

11
qhull-broken.patch Normal file
View file

@ -0,0 +1,11 @@
--- src/qhull/CMakeLists.txt.orig 2020-06-18 04:22:25.000000000 +0200
+++ src/qhull/CMakeLists.txt 2020-10-11 13:48:06.303764726 +0200
@@ -10,7 +10,7 @@
# see bug report: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=925540
-find_package(Qhull 7.2 QUIET)
+#find_package(Qhull 7.2 QUIET)
add_library(qhull INTERFACE)